Importing issue from Amazon
Incident Report for DSM Solutions
Resolved
This incident has been resolved.
Posted Jul 19, 2021 - 06:23 UTC
Identified
You may get issues while importing items from Amazon.
We are aware of it and are working on fix
Posted May 28, 2021 - 22:15 UTC
This incident affected: Rapid Lister and Bulk Lister.