Issue with updating amazon items
Incident Report for DSM Solutions
Resolved
This incident has been resolved.
Posted Sep 22, 2021 - 21:27 UTC
Investigating
techs are working on a fix, and soon changes will be applied to scan work
Posted Jul 19, 2021 - 06:25 UTC
This incident affected: Price Monitor.