The copy address button and the order button (paper plane) are missing
Incident Report for DSM Solutions
Resolved
This incident has been resolved.
Posted Jul 19, 2021 - 06:23 UTC
Investigating
The issue is under the investigation. Thank you for your patience!
Posted Jul 01, 2021 - 16:00 UTC
This incident affected: Sales & Orders.