DSM Chrome Extension does not auto paste the customer's details
Incident Report for DSM Solutions
Resolved
This incident has been resolved.
Posted Apr 14, 2021 - 13:57 UTC
Update
We are continuing to investigate this issue.
Posted Feb 26, 2021 - 11:13 UTC
Investigating
We are investigating the reported incident of being unable to auto paste the customer's information on Amazon.
Posted Feb 26, 2021 - 11:12 UTC
This incident affected: DSM Auto Paste Chrome Extension.